PortalParts.com Site

 Forum Index > Geeklog > Filemgmt Plugin Support New Topic Post Reply
 Filemgmt Plugin Version 1.5.3 released
 |  Printable Version
Blaine
 December 19 2007 10:17 AM  
Forum Admin
Admin

Status: offline

Registered: 03/01/02
Posts: 3576

Can you tell me what the error.log file is reporting when you try to install.

The plugin install would not fail due to directory permissions - assuming the webserver atleast has read access. The install routine is trying to create the new tables and register the plugin.

Once installed, you will need to follow the online config as per the install directions and to sucessfully upload files, you will need the directory permissions correct.


Please consider contributing to support my efforts ..
 
Profile Email Website PM
Quote
e-crins
 December 22 2007 15:37 PM  
Forum Newbie
Newbie

Status: offline

Registered: 12/19/07
Posts: 2

sorry for the delay...

Here goes:
Wed Dec 19 15:59:50 2007 - Attempting to install the filemgmt Plugin
Wed Dec 19 15:59:50 2007 - executing CREATE TABLE gl_filemgmt_category (
cid int(5)

unsigned NOT NULL auto_increment,
pid int(5) unsigned NOT NULL default '0',
title varchar(50) NOT NULL default '',
imgurl varchar(150) NOT NULL default

'',
`grp_access` mediumint(8) NOT NULL default '0',
PRIMARY KEY (cid),
KEY pid (pid)
) TYPE=MyISAM
Wed Dec 19 15:59:50 2007 - 1050: Tabel

'gl_filemgmt_category' bestaat al. SQL in question:
Wed Dec 19 15:59:50 2007 - Error Creating table
Wed Dec 19 15:59:50 2007 - Attempting to unregister the

Forum plugin from Geeklog
Wed Dec 19 15:59:50 2007 - Removing Table gl_filemgmt_category
Wed Dec 19 15:59:50 2007 - Removing Table gl_filemgmt_filedetail
Wed Dec 19 15:59:50 2007 - Removing Table gl_filemgmt_filedesc
Wed Dec 19 15:59:50 2007 - Removing Table gl_filemgmt_broken
Wed Dec 19 15:59:50 2007 -

Removing Table gl_filemgmt_votedata
Wed Dec 19 15:59:50 2007 - Removing Table gl_filemgmt_downloadhistory
Wed Dec 19 15:59:51 2007 - Removing filemgmt

Admin Group
Wed Dec 19 15:59:51 2007 - Removing root users from Admin Group of filemgmt
Wed Dec 19 15:59:51 2007 - Removing filemgmt User Group
Wed

Dec 19 15:59:51 2007 - Removing root users from Users Group of filemgmt
Wed Dec 19 15:59:51 2007 - Removing filemgmt.edit feature and rights to it
Wed Dec

19 15:59:51 2007 - DELETE FROM gl_access WHERE acc_ft_id =
Wed Dec 19 15:59:51 2007 - Removing filemgmt.user feature and rights to it
Wed Dec 19

15:59:51 2007 - DELETE FROM gl_access WHERE acc_ft_id = 51
Wed Dec 19 15:59:51 2007 - Removing filemgmt.upload feature and rights to it
Wed Dec 19

15:59:51 2007 - DELETE FROM gl_access WHERE acc_ft_id =
Wed Dec 19 15:59:51 2007 - Removing all comments for plugin filemgmt
Wed Dec 19 15:59:51 2007 -

Removing block definition for plugin filemgmt
Wed Dec 19 15:59:51 2007 - ...success

Hope it all makes sense to you...

Kind regards

Erik


 
Profile Email PM
Quote
Blaine
 December 22 2007 15:48 PM  
Forum Admin
Admin

Status: offline

Registered: 03/01/02
Posts: 3576

Once the install fails it de-installs itself and that sometimes can clean up an issue. Try again and this time post the error log using the bbcode [ code ] tags so the formatting is preserved when you post your response.


Please consider contributing to support my efforts ..
 
Profile Email Website PM
Quote
appie252001
 December 25 2007 03:58 AM  
Forum Newbie
Newbie

Status: offline

Registered: 12/25/07
Posts: 3

Hi Blaine,

After upgrading the plug-in to 1.5.3 I get a strange error when uploading a file. I don’t understand much of the code, but in the path (D:/web1/Geeklog-1.x/public_html/filemgmt_data/files/) there is a reference to public_html, and on this site I don’t have that directory, only a www. The public_html is normally not in my path.

Hope you can help me, I set all the files and directories to 755.

Albert


An error has occurred:
2 - move_uploaded_file(D:/web1/Geeklog-1.x/public_html/filemgmt_data/files/Mash Magazine december 2007.pdf) [function.move-uploaded-file]: failed to open stream: No such file or directory @ /var/accounts/CN20040179/mes/admin/plugins/filemgmt/index.php line 1306
array(9) {
["newfile"]=>
string(83) "D:/web1/Geeklog-1.x/public_html/filemgmt_data/files/Mash Magazine december 2007.pdf"
["directory"]=>
string(52) "D:/web1/Geeklog-1.x/public_html/filemgmt_data/files/"
["myts"]=>
&object(MyTextSanitizer)#55 (0) {
}
["eh"]=>
&object(ErrorHandler)#57 (0) {
}
["filemgmtDuplicatesAllowed"]=>
&NULL
["filemgmtFilePermissions"]=>
&int(493)
["name"]=>
string(31) "Mash Magazine december 2007.pdf"
["tmp"]=>
string(14) "/tmp/phpQ4g3xz"
["logourl"]=>
string(37) "Mash%20Magazine%20december%202007.pdf"
}
(This text is only displayed to users in the group 'Root')


 
Profile Email PM
Quote
appie252001
 December 25 2007 04:33 AM  
Forum Newbie
Newbie

Status: offline

Registered: 12/25/07
Posts: 3

Blaine,

Problem is even worse, I just found out that downloading a file is ending up in a blank screen?

I installed the bad behavior plug-in, but switching this off is not solving this problem.

Albert


 
Profile Email PM
Quote
Content generated in: 0.18 seconds
New Topic Post Reply



 All times are CDT. The time is now 03:51 PM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
Filtered HTML Allowed 
Censored Content