PortalParts.com Site

 Forum Index > Geeklog > ChatterBlock Plugin Support New Topic Post Reply
 Colors and style
 |  Printable Version
rick
 February 04 2008 10:22 AM (Read 2153 times)  
Forum Full Poster
Full Poster

Status: offline

Registered: 11/05/03
Posts: 11

Hi,

I have been using Chatterclock for some time now. I am trying to move two sites to a hosted environment and upgrade Geeklog to 1.4.1. One of my themes is not 1.4.1 and I am struggling to get it to work. I have read the changes in the documentation, but it does not seem easy and and I am not sure how to do this exactly. The other site is using a 1.4.1 theme.
I cannot seem to get the colors to change completly in my Chatterblock.
I have read step 4 in the instructions, and it does not seem clear to me.
I have added the contents of cb_style.css to my style.css file in my theme.
However, The background is not changing to the color I want, 861303
The color does show when a post is made, but the empty space below is still white.
Can someone give me a clue on how to resolve this, so that the background is always 861303?

Thanks.
Rick
Here are my changes:

PHP Formatted Code
cb_submitter     { color:#FFFFFF; font weight: bold;  font-size: 10px; font-family: verdana, arial, sans-serif; }
.cb_text1         { color:#FFFFFF; background-color:#861303; font-size: 12px; font-family: arial, serif;  }
.cb_text2         { color:#FFFFFF; background-color:#861303; font-size: 12px; font-family: arial, serif;  }
.cb_text3         { color:#FFFFFF; background-color:#861303; font-size: 10px; font-family: arial, serif;  }
.cb_chatcount     { color:#FFFFFF; weight: bold; font-size: 10px; font-family: verdana, arial, sans-serif; }
.cb_logtitle      { color:#FFFFFF; weight: bold; font-size: 12px; font-family: verdana, arial, sans-serif; }
.cb_logtextRow1   { color:#FFFFFF; background-color:#861303; font-size: 10px; font-family: verdana, arial, sans-serif;  }
.cb_logtextRow2   { color:#FFFFFF; background-color:#861303; font-size: 10px; font-family: verdana, arial, sans-serif;  }
.cb_adminRow1     { color:#FFFFFF; background-color:#861303; font-size: 10px; font-family: verdana, arial, sans-serif;  }
.cb_adminRow2     { color:#FFFFFF; background-color:#861303; font-size: 10px; font-family: verdana, arial, sans-serif;  }
.cb_lastpost      { color:#FFFFFF; font-size: 9px; font-family: verdana, arial, sans-serif;  }
.cb_delpost       { color:#FFFFFF; font-size: 9px; font-family: verdana, arial, sans-serif;  }
.cb_link          { color:#FFFFFF; font-size: 12px; line-height: 14px; font-family: Arial, Helvetica, Verdana; text-decoration: none }
.cb_link:hover    { color:#000000; font-size: 12px; line-height: 14px; font-family: Arial, Helvetica, Verdana; text-decoration: none }


 


 
Profile Email PM
Quote
rick
 February 05 2008 14:52 PM  
Forum Full Poster
Full Poster

Status: offline

Registered: 11/05/03
Posts: 11

Sorry, I meant to write Chatterblock above. I know it is no excuse, but I was tired :doh:


 
Profile Email PM
Quote
rick
 February 06 2008 15:15 PM  
Forum Full Poster
Full Poster

Status: offline

Registered: 11/05/03
Posts: 11

Hi Again,

I know Blaine is out travelling. Is there anyone else who knows where to change the background color (when there are no chat messages) ?
As soon as a message is posted the correct color appears behind that message, but below that message it is just white. It looks bad.

One funny thing is, that on my old server, I have not added the cb lines to my style.css, and yet the colors match the theme, including the background (without messages).

Another thing that is strange is in the old source of the old server there is a 'body background'. Where is this coming from?:

PHP Formatted Code

</script><head><link rel='stylesheet' href='http://www.grevepigerne.dk/layout/3AM/style.css' type='text/css'></head><head><style type="text/css">body { background:861303}</style></head><body onload = window.setTimeout("location.href='cb_iframeDisplay.php'",50000)><script language="javascript">
 


There is no body background in the new and I think this is why it is white:
PHP Formatted Code

</script><head><link rel='stylesheet' href='http://www.grevepigerne.dk/layout/3AM/style.css' type='text/css'></head><body onload = window.setTimeout("location.href='cb_iframedisplay.php'",300000)><script language="javascript">   


Thank you for any help pointing me in the rright direction.

Rick


 
Profile Email PM
Quote
rick
 February 06 2008 15:59 PM  
Forum Full Poster
Full Poster

Status: offline

Registered: 11/05/03
Posts: 11

Solved! I new I had worked with Blaine on this before. It is still difficult to change the color of the 'iFrame' apparently.
I found my post I was searching for.

The solution Blaine gave me in 2003:

Add this line to the cb_iframeDisplay.php file:

PHP Formatted Code

echo '<head><style type="text/css">body { background:861303 }</style></head>';
 


Thanks for listening :)

/Rick


 
Profile Email PM
Quote
Content generated in: 0.22 seconds
New Topic Post Reply



 All times are CST. The time is now 11:58 PM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
Filtered HTML Allowed 
Censored Content